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Introduction to MeshLab1

MeshLab is an advanced 3D mesh processing software system which is commonly used in the 
most technical fields of 3D development and data handling. MeshLab is open source software 
which is freely available under GNU (GPL) licence. It is used as a complete program and also as 
a library for other software programs.

MeshLab was developed by the ISTI-CNR investigation centre; MeshLab was initially created as 
course work at the University of Pisa at the end of 2005. The system is designed to transform 
typically unstructured 3D models arising from 3D digitalisation of pipelines. MeshLab is designed 
for managing and processing large unstructured meshes. It comes with a set of tools for editing, 
cleaning, repairing, inspecting, rendering and converting this type of mesh.

The automatic mesh cleaning filters include: the removal of duplicated, unreferenced vertices, 
non manifold edges and null faces. Remeshing tools based on quadric error measure, subdivision 
surfaces and surface reconstruction algorithms from point clouds based on the ball-pivoting 
technique and on the Poisson surface reconstruction approach. For noise removal, MeshLab 
offers various filters to smooth out noise, as well as tools for curve analysis and visualisation.

Includes a range map alignment tool based on the iterative closest point algorithm. MeshLab also 
includes an interactive mesh painting system allowing areas to be highlighted and any effects of 
noise to be smoothed out.

MeshLab is available for the majority of operating systems including Windows, Linux, Mac OS 
X, with reduced functionality for iOS and Android. The system is compatible with the following 
formats for both input and output: PLY, STL, OFF, OBJ, 3DS, VRML 2.0, U3D, X3D and COLLADA.

MeshLab also allows point clouds reconstructed using Photosynth to be imported.

Opening PLY files in MeshLab
Open the point cloud in MeshLab. The point cloud will have the “.ply” extension.

Opening MeshLab: you will see a menu at the top the main window of the program, and a tool 
bar underneath it, and finally, a 3D viewfinder that occupies the majority of the window.

1 Introduction to MeshLab http://en.wikipedia.org/wiki/MeshLab (27th February 2015)

Reconstructing the point cloud with MeshLab1
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Importing a Mesh file: File > Import Mesh.

Selecting the points model (.ply): go to Import Mesh, select the point cloud file that you want to 
import and then click on Open.

The Horus scanning software saves the point clouds as “.ply” files by default.

Viewing the point cloud: once the file has been imported, a 3D visualisation of that cloud will 
appear in the space.

If the point cloud was generated from a texture scan, the point cloud will reflect the colours of 
the scanning.

If it was generated from a simple scan without texture, all points will be displayed in the colour 
selected at the time of scanning.

Reconstructing the point cloud with MeshLab
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Cleaning the point cloud
The point cloud could contain imperfections and noise, or simply points that you do not want to 
be part of the final model. MeshLab enables you to select points of the cloud and delete them.

Select Vertexes tool: click on the Select Vertexes icon on the tool bar which enables you to select 
points in a three-dimensional space using a two-dimensional rectangle shape.

Selecting the vertexes: you can add more points to the selection by holding down the Control 
key while moving the left button of the mouse. The “+” symbol will appear next to the cursor.

You can also deselect points that you have previously selected by holding down the Shift key while 
moving the left button of the mouse. The “-” symbol will appear next to the cursor. You can select 
the vertexes by holding down the left button of the mouse and moving the cursor over the screen. 
The vertexes selected will be shown in red.

Once you have selected the vertexes that you want to delete, release the left button of the mouse.

Deleting unwanted vertexes: once you have selected the vertexes that you want to delete, click 
on the Delete Selected Vertex icon located on the tool bar.

Reconstructing the point cloud with MeshLab
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Clean point cloud: it is important that the point cloud to be reconstructed is largely free from 
noise. The reconstruction algorithm partly filters the noise, but it if the cloud has many points 
that do not belong to the model, the results of the reconstruction will not be accurate.

Processing the point cloud
In order to process a point cloud you will need to create the object normals:

Compute normals menu: Filters > Normals, Curvatures and Orientation > Compute normals for 
point sets).

Compute normals window: in this window you will need to change the Neighbour number, which 
reflects the number of close points needed to compute the normal.

The recommended initial values are 10, 50 or 100. You might need to adjust this value later. It 
is advisable to keep the defaults for all other values.

Once you have made the adjustment, click on the Apply button. The program will take a few 
seconds to compute the normals. Once it has finished click on the Close button.

Reconstructing the point cloud with MeshLab
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Showing the normals: the best reconstructions are generally achieved when the direction of 
the normals is facing away from the object.

To display the normals, go to Render > Show Normal/Curvature.

To hide them, go back to the same tab and click again to deselect.

Viewing the normals: the normals will appear as blue lines over the surface of the point cloud.

It could occur that some normals are not facing away from the exterior of the object. The 
geometry, the cloud density, and the neighbour number at the time of computing the normals 
will affect the result.

In the event of some of the normals not facing away from the exterior of the object, it is advisable 
to recompute the normals by varying the neighbour number until valid results are achieved.

Reconstructing the object from the point cloud
Using the normals generated in the previous section, you can proceed to reconstruct the object.

Reconstruction filter menu: Filters > Remeshing, Simplification and Reconstruction > Surface 
Reconstruction: Poisson.

Reconstructing the point cloud with MeshLab
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Reconstruction filter window: in this window you can modify the Octree Depth and Solver 
Divide values.

The recommended initial values are between 6 and 12 (if your computer is not very powerful 
the maximum recommended value is 11). It is advisable to keep the defaults for all other values.

As these variables are increased, the accuracy of the final model will also increase, however, the 
processing time will also be longer.

Once you have made the adjustment, click on the Apply button. The processing time can vary 
from a few seconds to several minutes. The “Not responding” window could appear during this 
time. Unless a pop-up window appears, do not close the window. The processing time depends 
on the specifications of the computer which is running the program. It is not advisable to use a 
low spec computer for processing point clouds.

Once the reconstruction process has finished, click on the Close button.

Viewing the results of the reconstruction
Once the reconstruction is finished, the layers of the point cloud and the reconstructed object 
will be overlapping. To only view the reconstructions results, simply hide the point cloud layer.

Reconstructing the point cloud with MeshLab
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Layer visualisation window: to show the layer visualisation window, click on View > Show Layer 
Dialog.

Hiding the point cloud layer: the eye icon that appears on the left of the name of each layer can 
be used to view each layer. Click on it to show or hide the layers.

The layer containing the point cloud will be hidden to improve the visualisation of the 
reconstruction.

Saving the results of the reconstruction
Export Mesh menu: this option is located under File > Export Mesh.

Reconstructing the point cloud with MeshLab
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Export window: select the Export Mesh As option to export a file in the STL format, select the 
location where you want to save it, then click on the Save button.

You should choose the STL format because all the slicing software programs used in 3D printing 
can open it correctly. If you want to export the file for other uses, you can select a different format.

Merging point clouds with MeshLab
The point cloud may sometimes be incomplete, due to the geometry of the scanned object or 
the number of lasers used during the scanning process. The solution is to scan the object again 
by placing it in different position on the platform or by using another laser. Then merge the 
two point clouds together. To explain how this method works, we have used two point clouds, 
however, this process can be carried out with as many point clouds as you like - the procedure 
remains the same.

Open the “.ply” files of the point clouds from the two scanning processes.

In the layer visualisation window (CTRL + L), select a layer and compute the normals. Once the 
process is finished, do the same with the other layer. Check that the graphic form (by viewing 
the normals of each layer) has been calculated correctly.

Align tool: to access the alignment tool, go to Edit > Align.

Reconstructing the point cloud with MeshLab
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Alignment panel: click on the first layer in the Align tool panel and then on the Glue Here Mesh 
button. This action will fix the first point cloud in the space.

Then select the second layer and press on the Point Based Glueing button and a new window 
will open.

This window enables you to position the point clouds so that it is easier to align the points. Then 
select at least four matching pairs of points on each of the point clouds. To select a point, simply 
double-click the mouse over the point cloud.

The points selected will be indicated numerically to prevent errors from occurring. If a point is 
not valid, you will need to click on Cancel and open the window again as there is no option to 
Undo.

Once you have selected the matching points on both clouds, click on OK.

Following the previous step, check that the point clouds have been aligned. If not, repeat the 
previous step until they are correctly aligned.

To complete the alignment click on Process.

Reconstructing the point cloud with MeshLab
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Visualisation of the aligned point clouds: you can check the results of the alignment simply by 
looking at it, the details improve and the missing points are corrected.

Merging point clouds 
The point clouds aligned at the previous step are not joined, meaning that they are two separate 
point clouds.

You will need to merge them together in order to reconstruct the object.

Merging layers menu
Merging visible layers: to access the tool for merging visible layers, go to the Filters menu: Filters 
> Mesh Layer > Flatten Visible Layers..

Merging visible layers menu: in this window the select the Keep unreferenced vertices option.

Then click on Apply

Reconstructing the point cloud with MeshLab
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The result of merging the point clouds is a new point cloud with a better resolution.

Once the layers have been joined, recompute the normals of the new point cloud. To obtain the 
reconstructed model, as was previously explained. 

Smoothing out the reconstruction results
When objects are reconstructed from a point cloud, the result might not be not totally accurate. 
The missing points affect the reconstruction and the lack of points cannot always be resolved by 
merging various point clouds together.

An example of such an object could be the object shown earlier; the base of the object cannot 
be scanned (as it is supported by the base) and the top part has no points due to the geometry.

However, the reconstruction algorithm will always attempt to close the faces in order to achieve 
a closed surface.

As you can see, the reconstruction process has closed the top and bottom parts, but there is still 
room for improvement.

To improve the results, you can apply smoothing filters to any areas which have been poorly 
reconstructed.

Reconstructing the point cloud with MeshLab

Top part before reconstruction

Top part after reconstruction

Bottom part before reconstruction

Bottom part after reconstruction
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Face selection tool: this tool works in the same way as Select Vertexes, the sole difference is that 
it selects faces instead.

 

Selecting inaccurate faces: as with the other tool, right-click the mouse and move the cursor to 
select the faces that you want to smooth out.

It is important to remember that as well as selecting the visible faces, you will also need to select 
the ones in the rectangular box, which are not visible from this perspective.

To deselect faces that you have selected but do not want to modify, left-click on Select Faces in a 
rectangular region on the tool bar again. The position of the object will change, click on the face 
selection tool again. During this process the faces that were selected previously remain selected. 
Finally, press the Shift key while moving the cursor over the faces that you do not want to modify.

Once you have made sure that only the faces to be smoothed out are selected, click on Select 
Faces in a rectangular region. The faces remain selected.

Smoothing filter menu: the Taubin Smooth filter is applied to the selected faces, which is accessed 
via Filters > Smoothing, Fairing and Deformation > Taubin Smooth.

Reconstructing the point cloud with MeshLab
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Taubin Smooth filter: in the Taubin Smooth window, various parameters can be adjusted.

It is recommended to enable Preview by the ticking box so that the effects of adjusting the 
parameters on the object can be viewed in real time.

It is also recommended to keep the default Lamda value. In the example Mu and Smoothing Steps 
have been modified.

The parameters will be different depending on the error of the faces created during reproduction, 
so it is advisable to try different values until you achieve the correct result.

After you have adjusted the parameters to the desired values, click on the Apply button.

The result of applying the smoothing filter is significant. Applying the smoothing filter to all faces 
reduces the detail of the object, so it is important to only apply it to the inaccurate faces.

Reconstructing the point cloud with MeshLab

Top part after applying the smoothing filter Bottom part after applying the smoothing filter
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Introduction to CloudCompare2

CloudCompare is a program for processing point clouds (such as those obtained using a 3D 
scanner). It also processes triangular meshes and calibrated images.

This software was created during a collaboration between Telecom ParisTech and the R&D 
division of EDF. The CloudCompare project was launched in 2003 with the doctoral thesis of 
Daniel Girardeau-Montaut on Detection of Changes in 3D Geometric Data. At that time, his 
main aim was to rapidly detect changes in high density point clouds generated by laser scanners 
in industrial facilities (such as power stations) or on construction sites. It later evolved into a 
more general and advanced 3D data processing software program. It is now is an independent 
and freely available open source software.

CloudCompare provides a basic set of tools for editing and rendering point clouds and triangular 
meshes. It also offers various advanced processing algorithms to perform tasks such as: 
projections, records, distance calculations, statistics, segmentation or estimation of geometric 
characteristics.

CloudCompare is available on Windows, Linux and Mac OS X, for both 32-bit and 64-bit 
architectures. It is developed in C ++ with Qt.

Opening PLY files in CloudCompare
Open the point cloud with the “.ply” extension In CloudCompare.

Opening CloudCompare: you will see a menu at the top the main window of the program and a 
tool bar underneath it on the right, a console at the top and finally, the 3D viewfinder.

2 Introduction to CloudCompare http://en.wikipedia.org/wiki/CloudCompare (27th February 2015)

Reconstructing the point cloud with 
CloudCompare2

Reconstructing the point cloud with CloudCompare

http://en.wikipedia.org/wiki/CloudCompare
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Importing a Mesh file: go to File > Open.

Selecting the points model (.ply): from the Open window, select the point cloud file that you 
want to process. Once you have select the file, click on Open.

The Horus scanning software saves the point clouds as “.ply” files by default. You will need to 
select this file type from the drop-down menu.

Properties of “.ply” files: this window displaying advanced configuration options will appear 
when a “.ply” file is opened. It is recommended to keep the default values. To continue to open 
the file, click on Apply.

Reconstructing the point cloud with CloudCompare
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Viewing the point cloud: once the point cloud has been imported, you will be able to see view 
it in the 3D viewfinder window.

If the point cloud was generated from a texture scan, you will see the point cloud in the colours 
of the scanning.

If it was generated from a simple scan without texture, all points will be displayed in the colour 
selected at the time of scanning.

Cleaning the point cloud
The point cloud could contain imperfections and noise, or simply points that you do not want to 
be part of the final model. CloudCompare enables you to select points of the cloud and delete 
them.

Segmentation tool: the first step for cleaning the point cloud is to select the layer than contains 
it. Click on the layer named Cloud in the file tree on the the left side.

The click on the Segment icon on the tool bar.

This tool enables you to select points in a three-dimensional space using a two-dimensional 
polygon or a rectangle. How? Think of this tool as a box for modifying one of the faces, which 
selects all of the points within it from front to back.

Reconstructing the point cloud with CloudCompare
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Pause and position: occasionally, the points to be eliminated might not be visible from the initial 
view. The Segment tool consists of various actions which include: Pause, Selection, Segment In, 
Segment Out, Clear segmentation, Confirm segmentation, Confirm and delete hidden points and 
Cancel.

The Pause button enables you to move freely across the point cloud without selecting any points. 
Once the cloud is in the desired position, click on Pause again to start selecting points.

Segment Out: the Selection option enables you to select the points using a polygon with the 
vertexes marked or using the rectangle.

To use the Polygonal selection, left-click the mouse where you want the first vertex to be located, 
then click again where you want the second vertex to be located, and so on. Once you have 
defined the polygonal selection, right-click the mouse. Then click on one of the segmentation 
options.

There are two segmentation options: Segment In or Segment Out.

With the Segment Out option, the points outside of the selection polygon remain visible, whereas 
those within it are moved to another hidden layer.

Reconstructing the point cloud with CloudCompare
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Segment In: in contrast, with the Segment In option, the points within the selection polygon 
remain visible and those outside of it are moved to another hidden layer.

Cleaning the point clouds: the unwanted points will no longer appear after segmentation.

There are two options for completing the segmentation process. The first option is to Delete 
hidden points, which removes any points which have been previously selected and are hidden.

The second option is Confirm segmentation, which separates the unwanted points from those 
to be kept in different layers.

 

Eliminating the layer of unwanted points: if you have selected Confirm segmentation, it is 
advisable to delete the layer of unwanted points. To do this, click on the layer that contains 
them and then right-click it. Select Delete from the drop-down menu.

Reconstructing the point cloud with CloudCompare
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Results of cleaning the point clouds: once the point cloud has been cleaned, you will see that 
the yellow edges of the box containing the point cloud fits much better than at the beginning.

Cleaning the point clouds is important if you want to obtain the best results.

Processing the point cloud
In order to process a point cloud you will need to create the object normals:

Compute normals menu: the first step is to select the layer containing the point cloud which 
you want to compute the normals for.

Go to Edit > Normals > Compute.

Compute normals window: here you will need to adjust the orientation. It is recommend to use 
the –Barycenter orientation and to keep the default values for the rest.

Once you have adjusted the settings, click on Apply. The program will take a few seconds to 
compute the normals. Once it has finished click on the Close button.

Reconstructing the point cloud with CloudCompare
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Showing the normals: the normals visualisation is enabled by default. If not, you can do this by 
right-clicking on the layer that the normals have been computed for, and then click on Toggle 
normals. To hide them, click on the same tab again.

For an accurate reconstruction, the normals must be facing away from the piece, mean that, the 
object will be black (the colour of the normals). If the exterior of the object is not black but the 
interior is, this means that the normals have been computed backwards.

In the tests carried out -Barycenter is selected as the orientation parameter and the normals are 
always computed away from the object. However, if they have been computed backwards, they 
can be inverted by going to Edit > Normals > Invert.

Reconstructing the object from the point cloud
From the normals generated in the previous section, you can proceed to reconstruct the object.

Reconstruction tool menu: you can access the point cloud reconstruction tool via Plugins > 
Poison Surface Reconstruction.

Click on it to open the tool window.

Reconstructing the point cloud with CloudCompare
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Reconstruction tool window: in this window you can modify the Octree Depth value

The recommended values are between 6 and 12 (if your computer is not very powerful the 
maximum recommended value is 11). It is advisable to keep the defaults for all other values.

As these variables are increased, the accuracy of the final model will also increase, however, the 
processing time will also be longer.

Once you have adjusted the value, click on OK. The processing time can range from several 
seconds to several minutes, depending on the specifications of the computer which is running 
the program. 

It is not advisable to use a low spec computer for processing point clouds.

Importing colours from the point cloud to the reconstruction: once the reconstruction process 
has finished, a window will appear asking if you want to import the colours of the point cloud to 
the reconstruction.

If you have scanned with texture, or without texture but you want to retain the colour of the 
point cloud, click on Yes. The process of importing the colour may last from a few seconds to a 
few minutes, depending on the number of points that the cloud has and the specifications of the 
computer running the process.

If you do not want to import the colour, click on No.

Reconstructing the point cloud with CloudCompare
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Saving the results of the reconstruction
Save menu: to save the results of the reconstruction it is important to select the Mesh layer. Then 
click on File > Save.

Save window: save it STL format, select the location where you want to save it, then click on 
the Save button. 

You should choose the STL format because all the slicing software programs used in 3D printing 
can open it correctly. If you want to export the file for other uses, you can select a different 
format.

Merging point clouds with CloudCompare
The point cloud may sometimes be incomplete, due to the geometry of the scanned object or 
the number of lasers used during the scanning process. The solution is to scan the object again 
by placing it in different position on the platform or by using another laser. Then merge the 
two point clouds together. To explain how this method works, we have used two point clouds, 
however, this process can be carried out with as many point clouds as you like - the procedure 
remains the same.

Open the “.ply” files of the point clouds from the two scanning processes.

Reconstructing the point cloud with CloudCompare
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Align tool: select the layers that you want to align and click to open the tool. The Align icon is 
located on the tool bar.

A window will then appear showing the “reference” layer (yellow) and the layer “to align” (red).

Click on Swap. The reference layer and the layer to align will have changed places.

Click on OK to continue aligning the layers.

Selecting point on the layer to be aligned: in this window the point clouds can be oriented to 
make it easier to align the points.

Then select at least four matching pairs of points on each of the point clouds to be aligned. 
Being overlapped, we recommend ticking the “Show reference cloud” box to hide it and facilitate 
selection of the points.

To select a point of the cloud, simply click on it. If you want to deselect a particular point, click on 
the button marked with an X, to the right of the point coordinates.

The points are accompanied by a letter and a number. Letter “A” indicates a point belonging to 
the layer to be aligned, and the number indicates the order that the points were selected in. 

Reconstructing the point cloud with CloudCompare
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Selecting points on the reference layer: once the points have been selected on the layer to be 
aligned, select the corresponding points on the reference layer.

In order to select points on the reference layer, it is useful to hide the other layer, although you 
will most likely need to show from time to time in order to remember the location of the point 
on that layer.

The points must be selected in the same order, as the order of selection is very important. In 
order to obtain good results, very similar points must be selected in both layers.

As with the other layer, the selected points are accompanied by a letter and a number. Letter “R” 
indicates a point belonging to the layer to be aligned, and the number indicates the order that 
the points were selected in.

Once the points have been selected on both layers, click on Confirm.

Align info: a pop-up window will appear containing information on the cloud alignment process. 
Click on OK to continue.

Viewing the results of alignment: simply by looking, you can see that the point cloud resulting 
from the alignment process is denser, which makes the results of the reconstruction more 
accurate.

Reconstructing the point cloud with CloudCompare



27

GUIDE TO POST-PROCESSING OF THE POINT CLOUD

Merging point clouds: the clouds are now aligned, but they have not yet been merged. To merge 
the clouds, you will need to select them and then click on: Edit > Merge.

The normals can now be computed and the object reconstructed, as explained earlier.

Printing the results of the reconstruction
There is one disadvantage when it comes to processing point clouds in CloudCompare: in general 
it does not close the objects. Taking the totem as an example, once the top and bottom have been 
reconstructed, they remain open and the object is hollow inside.

This can cause problems when printing the 3D model, as the program could recognise the object 
as a hollow cylinder and would print only the walls.

We will explain how to resolve this problem later, using the Cura slicing and printing software.

Running Cura: this is the main window of the Cura program. There is a menu at the top, a panel 
with four tabs on the left and a 3D viewfinder that occupies most of the window. 

Opening a 3D model: to open a 3D model, click on File > Load model file...

Reconstructing the point cloud with CloudCompare
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Open model window: in this window, you can browse the directories and select the 3D model 
to be printed.

Once you can selected the file, click on Open.

Visualisation of the model: once open, the 3D model will appear in the window. Right click and 
hold to change the orientation and use the mouse wheel to adjust the zoom.

From this view you can see that our 3D model is hollow.

Viewing the printing layers: occasionally, Cura will detect hollow objects and fill them 
automatically. If the reconstruction of the object has left points inside the model, it will not be 
filled automatically.

The best way to see if the model will to be printed correctly is by changing the view to Layers 
mode, where you will see how the layers will be printed by the printer.

Reconstructing the point cloud with CloudCompare
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Incorrect slicing: to check whether Cura has automatically filled the model, change the view to 
Layers mode.

The bar on the right indicates the number of layers in view. Slide the bar up or down to see more 
or less layers.

To check the filling of the object, ideally go to one of the in-between layers of the model. The 
program may take some time to process the layers. If the model is shown as hollow after the 
processing has finished, it has not been filled automatically. 

 On the other hand, if a mesh is shown inside the model, it has been filled automatically and you 
can now proceed to print it.

The image on the left shows a sliced model which has not been filled automatically by the 
program.

Expert configuration: to resolve the filling issue of the model, open the Expert config window.

To open this window, go to Expert > Open Expert Settings.

Under Fix horrible, only the Combine everything (Type-A) box is ticked by default, to fill the entire 
model you will need to tick Combine everything (Type-B).

Then click on OK.

Reconstructing the point cloud with CloudCompare
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Correct slicing: to check that the changes make in Expert config have resolved the filling issue, 
as before, you will need to view one of the in-between layers again.

The image on the left shows the model perfectly filled and ready for printing. 

Save menu: last of all, to save the printing file (GCode) click on File > Save GCode.

Reconstructing the point cloud with CloudCompare

Once the printing 
file (GCode) has 
been generated, it is 
important to open the 
expert configuration 
again and reverse the 
changes that were 
made. Failing this, errors 
and unwanted fillings 
could occur next time 
you slice.
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Save window: the save window will then appear. Via this window, you can browse the directory 
and save the file in the desired location.

Once you have entered the file name and selected the location click on Save.

Reconstructing the point cloud with CloudCompare
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